Incident

No longer supporting Internet Explorer 11 (IE11)

Resolved | Feb 29, 2024 | 18:00 GMT+01:00

As of 29th February 2024 we've dropped support for Internet Explorer 11.
Impact Stack pages and forms will no longer work in this browser.

If you have any questions about this, please reach out to support@more-onion.com

Monitoring | Feb 29, 2024 | 17:00 GMT+01:00

As of 29th February 2024 we've dropped support for Internet Explorer 11 (IE11).
Impact Stack pages and forms will no longer work in this browser.

Status Page powered by Admin Labs