Incident

Unexpected downtime / slower loading speed for our webservers

Resolved | Jun 30, 2023 | 14:49 GMT+02:00

Earlier issues with our webservers have now been fixed and all services are running as they should.

These issues limited the functionality and loading speed of Impact Stack installations on June 30th 2023 from 9:11 - 9:42 CEST.

Affected components

  • Auto-complete
  • Content Management
  • Email
  • Email to Target Datasets
  • Forms
  • New CRM

Monitoring | Jun 30, 2023 | 09:11 GMT+02:00

On Friday morning, 30th July between 9:11 - 9:42 CEST, our webservers experienced an unexpected downtime, due to a deliberate DDoS (Distributed Denial of Service) attack on one of our client installations with the goal to overload our servers. This affected all sites and resulted in slower loading speed or unavailability during that time.

The issue has now been resolved and all services are running as they should.

We understand that unscheduled downtime is, at the very least, inconvenient, and we're sorry this has happened. Our team is working hard to prevent incidents like this from happening again in the future.

Status Page powered by Admin Labs